Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^[a-z0-9]+(?:[.\-_'+][a-z0-9]+)*@([a-z0-9]+(?:[-][a-z0-9]+)*\.)+[a-z]{2,}$
/
igm
Input 1
1
New
Valid emails: user@domain.ru na_me.lastname@subdomain.domain.ru name-lastname@7.sub-sub-domain.subdomain.domain.ru ni+ck'name-name.lastname@d.oma-in-domain.ru Invalid addresses in the user section: .user@domain.ru user.@domain.ru -user@domain.ru user-@domain.ru us..er@domain.ru us--er@domain.ru Invalid addresses in the domain section: user@-domain.ru user@.subdomain.domain.ru user@subdomain-.domain.ru user@subdomain..domain.ru user@domain.-domain.ru user@dom--ain.ru