#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?:[^@a-zA-Z0-9]*[a-zA-Z0-9]){2})[a-zA-Z0-9_.-]+@[a-zA-Z0-9.-]+$"
Local $sString = "__z@gmail.com" & @CRLF & _
" invalid(because only one alphanumeric character before @)" & @CRLF & _
"z@gmail.com" & @CRLF & _
" invalid(because only one alphanumeric character before @)" & @CRLF & _
"" & @CRLF & _
"__zz@gmail.com" & @CRLF & _
"Z_Z@gmail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")