import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:INSERT INTO|UPDATE|SELECT|WITH|DELETE)(?:[^;']|(?:'[^']+'))+;\\s*$";
final String string = "SELECT * FROM database;\n"
+ "SELECT * FROM database WHERE somefield = 'somevalue';\n"
+ "SELECT * FROM database WHERE somefield = 'somevalue' AND someotherfield = 'somemistypedstring;\n\n"
+ "SELECTing is hard, though, this is just text!;\n\n"
+ "SELECT\n"
+ " *\n"
+ "FROM\n"
+ " test_table\n"
+ "WHERE\n"
+ " test_row = 'Testing ; semicolon';\n\n"
+ "SELECT * FROM another_test_table;\n\n"
+ "INSERT INTO \n"
+ " table_name \n"
+ "VALUES \n"
+ " (value1,'value which contains semicolon ;;;;',value3,...);";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}