re = /^(?:INSERT INTO|UPDATE|SELECT|WITH|DELETE)(?:[^;']|(?:'[^']+'))+;\s*$/m
str = 'SELECT * FROM database;
SELECT * FROM database WHERE somefield = \'somevalue\';
SELECT * FROM database WHERE somefield = \'somevalue\' AND someotherfield = \'somemistypedstring;
SELECTing is hard, though, this is just text!;
SELECT
*
FROM
test_table
WHERE
test_row = \'Testing ; semicolon\';
SELECT * FROM another_test_table;
INSERT INTO
table_name
VALUES
(value1,\'value which contains semicolon ;;;;\',value3,...);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end