const regex = /\d{1,2}d\d{1,2}h\d{1,2}m\d{1,2}s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{1,2}d\\d{1,2}h\\d{1,2}m\\d{1,2}s', 'gm')
const str = `jihsdfj23jh453h4 1d12h30m10s jhsedfujht34uhji3g
минусы эттой регулярки:
99d99h61m80s `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}