using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d\K\s+(\d)";
string substitution = @"$1";
string input = @"old iccid : 809831 3245 345 new iccid : 999000 112221";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}