const regex = /\d\K\s+(\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d\\K\\s+(\\d)', 'g')
const str = `old iccid : 809831 3245 345 new iccid : 999000 112221`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);