re = /(?<!\S)\d+(?:\/\d+)?\s[A-Za-z].*?(?=\s+\d+\b|$)/m
str = '17 Howard Rd Howard. Stdnt 11/169 Wall Road, Wontown, Wkr 105 AGNEW, Marilyn Barbara 106 AGNEW, Mavis Rosina'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end