import Foundation
let pattern = #"(?<!\d(?=.\d))\."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
.a.b.1.2.
.a.b.1..2.
.a.b.1..2...1.1
.1.a..1..1.....1.1......1
-a-b-1.2-
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)