#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\S*)?(:\/\/)?(?<interesting>.*)(:)?\/"
Local $sString = "ap://167.172.44.255:1389/LegitimateJavaCla" & @CRLF & _
"ap://167.172.44.255:1389/La" & @CRLF & _
"ap://167.99.32.139:1389/Basic/ReverseShell/167.99.32.139/99" & @CRLF & _
"ldap://x.x.x.x.61k2ev3252274o2ek77941q85t0r9444o.interact.sh/ok6ll9m" & @CRLF & _
"ldap://c6ps4rekeidcvgqlsmsgcg37qdoyyknz4.interact.sh/a" & @CRLF & _
"ldap://c6ps4rekeidcvgqlsmsgcg37x9ayymcak.interact.sh/a" & @CRLF & _
"ldap://c6ps4ipurnhssm2608l0cg37chyyykyhk.interact.sh/a" & @CRLF & _
"ldap://c6ps4ipurnhssm2608l0cg37pdyyykbug.interact.sh/a" & @CRLF & _
"91fd9fef8958.bingsearchlib.com:39356/" & @CRLF & _
"550f7e1deaed.bingsearchlib.com:39356/a" & @CRLF & _
"2174d47e8d04.bingsearchlib.com:39356/a" & @CRLF & _
"da6d408517b9.bingsearchlib.com:39356/a" & @CRLF & _
"5463610592ef.bingsearchlib.com:39356/a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")