$re = '/[^\s;,]+/m';
$str = '12f3,, 456;;;;
227- , 999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);