#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)('''|"""|["'])((?:\\.|.)*?)\1"
Local $sString = "print("This is also an NL test")" & @CRLF & _
"variable = "!\n"" & @CRLF & _
"print('And this has an escaped quote "don\'t" in it ', variable," & @CRLF & _
" "This has a single quote ' but doesn\'t end the quote as it" + \" & @CRLF & _
" " started with double quotes")" & @CRLF & _
"if "Foo Bar" != '''Another Value''':" & @CRLF & _
" """" & @CRLF & _
" This is just nonsense" & @CRLF & _
" """" & @CRLF & _
" aux = '?'" & @CRLF & _
" print("Did I \"failed\"?", f"{aux}")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")