# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\r?\n(?!\s)"
test_str = ("\\r?\\n(?!\\s)\n\n\n\n"
"Primer ejemplo:\n\n"
"Esta esta linea no se une a la anterior\n\n"
"Segundo ejemplo:\n"
"Esta linea se une a la anterior\n\n"
" Primer ejemplo:\n"
" Esta esta linea no se une a la anterior\n"
" Segundo ejemplo: Esta linea se une a la anterior")
subst = " "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.