using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[-a-zA-Z0-9#$%'_]+(\.[-a-zA-Z0-9#$%'_]+)*@(([-a-zA-Z0-9]+)\.)+(?!\d+$)[a-zA-Z0-9]{2,}$";
string input = @"Aba@example.com
test@test-test.com.com
test.abc-efg'@test-test.com.com.01111co
simple@example.com
very.common@example.com
other.email-with-hyphen@example.com
fully-qualified-domain@example.com
example-indeed@strange-example.com
example@s.example
Abc.example.com
A@b@c@example.com
just""not""right@example.com
this is""not\allowed@example.com
1234567890123456789012345678901234567890123456789012345678901234+x@example.com
john..doe@example.com
john.doe@example..com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}