$re = '/\b([1-9]|[1-9][0-9]|100)\b/';
$str = '1 1 1 21 23 1 99 100 101 201 999 01 007';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);