import Foundation
let pattern = #"(?<date>\d{4}-\d{2}-\d{2}) (?<time>\d{2}_\d{2}_\d{2})(-| - )(?<window>.*?)(?<extension>\.(png|jpg|jpeg))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2017-08-31 18_57_42-HandBrake.png
2017-08-31 18_57_43-HandBrake.png
2017-08-31 18_57_42-HandBrake - Kopie.png
2017-08-31 18_57_42-HandBrake2.png
2019-03-09 11_11_09 - musicBee - 000003.png
should fail.png'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)