#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\+[0-9]{1,2})?(\.|\ |\-)?([0-9]{1,3}(\.|\ |\-)?){5,6}$"
Local $sString = "0084966713061" & @CRLF & _
"84966713061" & @CRLF & _
"09661331313" & @CRLF & _
"123456" & @CRLF & _
"+33.434.34.34.34" & @CRLF & _
"01 23 45 67 89" & @CRLF & _
"+33 1 23 45 67 89" & @CRLF & _
"+33.1.23.45.67.89" & @CRLF & _
"+1.234.234.356.1213:2324" & @CRLF & _
"abdfaksdf" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")