// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\+[0-9]{1,2})?(\.|\ |\-)?([0-9]{1,3}(\.|\ |\-)?){5,6}$").unwrap();
let string = "0084966713061
84966713061
09661331313
123456
+33.434.34.34.34
01 23 45 67 89
+33 1 23 45 67 89
+33.1.23.45.67.89
+1.234.234.356.1213:2324
abdfaksdf
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}