import re
regex = re.compile(r"(?<!^\s*)(?=<GTOL-[A-Z]+>)", flags=re.MULTILINE)
test_str = ("<GTOL-POSI>.010<MOD-MMC>B-C<GTOL-POSI>.002<MOD-FMC>\n\n"
"<GTOL-POSI><MOD-DIAM>.004<MOD-MMC>HC<MOD-MMC><GTOL-POSI>.030<MOD-MMC>D-E<MOD-FMC>\n\n"
" <GTOL-POSI><MOD-DIAM>.005<MOD-MMC>AD-E<MOD-MMC><GTOL-PERP>.001A")
subst = "\\n\\n"
result = regex.sub(subst, test_str)
if result:
print(result)