using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[Hh]ot\s?[sS]wap|.?HS?.";
string input = @"hotswap
Hotswap
hot swap
Hot swap
Hot Swap
HS
HS>
>HS>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}