package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[Hh]ot\s?[sS]wap|.?HS?.`)
var str = `hotswap
Hotswap
hot swap
Hot swap
Hot Swap
HS
HS>
>HS>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}