const regex = /[Hh]ot\s?[sS]wap|.?HS?./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[Hh]ot\\s?[sS]wap|.?HS?.', 'gm')
const str = `hotswap
Hotswap
hot swap
Hot swap
Hot Swap
HS
HS>
>HS>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}