using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""ms_played"":\s""(\d*)""";
string input = @"""somedata"", ""ms_played"": ""0815"", ""somedata""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}