package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"ms_played":\s"(\d*)"`)
var str = `"somedata", "ms_played": "0815", "somedata"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}