const regex = /url\(['"]?(?!(?:\w{3,4}:))([^\)'"]+?)['"]?\)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('url\\([\'"]?(?!(?:\\w{3,4}:))([^\\)\'"]+?)[\'"]?\\)', 'gi')
const str = `url(http://blah.jpg)
url(../images/blah.jpg)
url('../images/blah.png')
url(data:image/png,base64,xxxxxxx)
url("../images/blah.svg")
url("FTP://images/blah.svg")
URL('//images/blah')
url('ftpfolder/blah.jpg')
url(https://nice.com/yo.jpg)
url(ftps://nice.com/yo.jpg)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}