using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([{,]\s*"")app\.kubernetes\.io\/([^""]+""\s*:)";
string substitution = @"$1app_kubernetes_io_$2";
string input = @"{ ""kubernetes"": { ""labels"": { ""app.kubernetes.io/name"": ""name"", ""app.kubernetes.io/version"": ""1.2.3"", ""no-match-field"": ""app.kubernetes.io/name"" } } }";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}