import Foundation
let pattern = #"([{,]\s*")app\.kubernetes\.io\/([^"]+"\s*:)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{ "kubernetes": { "labels": { "app.kubernetes.io/name": "name", "app.kubernetes.io/version": "1.2.3", "no-match-field": "app.kubernetes.io/name" } } }"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1app_kubernetes_io_$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)