import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Z]{2}[ \\-]?[0-9]{2})(?=(?:[ \\-]?[A-Z0-9]){9,30}$)((?:[ \\-]?[A-Z0-9]{3,5}){2,7})([ \\-]?[A-Z0-9]{1,3})?$";
final String string = "XX00 1234 5678 9012 3456 7890 1234 5678 90\n"
+ "YY00123456789012345678901234567890\n"
+ "----\n"
+ "AL28 BBB SSSSK CCCC CCCC CCCC CCCC\n"
+ "AD24-BBBB-SSSS-CCCC-CCCC-CCCC\n"
+ "BE16 BBBC CCCC CCKK\n"
+ "BA20 BBBS SSCC CCCC CCKK\n"
+ "BG22-BBBB-SSSS-DDCC-CCCC-CC\n"
+ "CY28 BBBS SSSS CCCC CCCC CCCC CCCC\n"
+ "DK18 BBBB CCCC CCCC CC\n"
+ "DE22 BBBB BBBB CCCC CCCC CC\n"
+ "EE20 BBSS CCCC CCCC CCCK\n"
+ "FO18 CCCC CCCC CCCC CC\n"
+ "FI18 BBBB BBCC CCCC CK\n"
+ "FR27 BBBB BSSS SSCC CCCC CCCC CKK\n"
+ "GE22 BBCC CCCC CCCC CCCC CC\n"
+ "GI23 BBBB CCCC CCCC CCCC CCC\n"
+ "GR27 BBBS SSSC CCCC CCCC CCCC CCC\n"
+ "GL18 BBBB CCCC CCCC CC\n"
+ "HU28 BBBS SSSK CCCC CCCC CCCC CCCK\n"
+ "IE22 BBBB SSSS SSCC CCCC CC\n"
+ "IS26 BBBB TTCC CCCC XXXX XXXX XX\n"
+ "IL23 BBB SSS CCCCCCCCCCCCC\n"
+ "IT27 KBBB BBSS SSSC CCCC CCCC CCC\n"
+ "JO27 BBBB CCCC CCCC CCCC CCCC CCCC CC\n"
+ "HR21 BBBB BBBC CCCC CCCC C\n"
+ "LV21 BBBB CCCC CCCC CCCC C\n"
+ "LB28 BBBB CCCC CCCC CCCC CCCC CCCC CC\n"
+ "LI21 BBBB BCCC CCCC CCCC C\n"
+ "LT20 BBBB BCCC CCCC CCCC\n"
+ "LU20 BBBC CCCC CCCC CCCC\n"
+ "MK19 BBBC CCCC CCCC CKK\n"
+ "MT31 BBBB SSSS SCCC CCCC CCCC CCCC CCC\n"
+ "MU30 BBBB BBSS CCCC CCCC CCCC RRRD DD\n"
+ "MC27 BBBB BSSS SSCC CCCC CCCC CKK\n"
+ "ME22 BBBC CCCC CCCC CCCC KK\n"
+ "NL18 BBBB CCCC CCCC CK\n"
+ "NO15 BBBB CCCC CCK\n"
+ "AT20 BBBB BCCC CCCC CCCC\n"
+ "PL28 BBBS SSSK CCCC CCCC CCCC CCCC\n"
+ "PT25 BBBB SSSS CCCC CCCC CCCK K\n"
+ "RO24 BBBB CCCC CCCC CCCC CCCC\n"
+ "SM27 KBBB BBSS SSSX XXXX XXXX XXX\n"
+ "SA24 BBCC CCCC CCCC CCCC CCCC\n"
+ "RS22 BBBC CCCC CCCC CCCC KK\n"
+ "SK24 BBBB SSSS SSCC CCCC CCCC\n"
+ "SI19 BBSS SCCC CCCC CKK\n"
+ "ES24 BBBB SSSS KKCC CCCC CCCC\n"
+ "CZ24 BBBB SSSS SSCC CCCC CCCC\n"
+ "TR26 BBBB BRCC CCCC CCCC CCCC CC\n"
+ "TN24 BBBB BCCC CCCC CCCC CCCC\n"
+ "GB22 BBBB SSSS SSCC CCCC CC\n"
+ "AE23 BBBB SSSS CCCC CCCC CCC\n"
+ "SE24 BBBB CCCC CCCC CCCC CCCC\n"
+ "CH21 BBBB BCCC CCCC CCCC C";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}