const regex = /([{,]\s*)"field\.with\.dots"(\s*:)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([{,]\\s*)"field\\.with\\.dots"(\\s*:)', 'gm')
const str = `{ "field.with.dots": "", "field-with-dots" : "field.with.dots", "field.with.dots":"" }`;
const subst = `$1"field_with_dots"$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);