re = /^(([a-zA-Z0-9_\.\-])+\@(([a-zA-Z0-9\-])+\.)+([a-zA-Z0-9]{2,4}){1}($|\;([a-zA-Z0-9_\.\-])+\@(([a-zA-Z0-9\-])+\.)+([a-zA-Z0-9]{2,4}))+)$/
str = 'test.namex@society.co.uk;john.doe@mail.fr;iris.queen@sun.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end