import re
regex = re.compile(r"\b(?:(?:[a-f\d]{2})(?:[:-]|)){6}\b", flags=re.IGNORECASE)
test_str = ("This is an example of a MAC address, for example 8C:C1:21:A2:44:A3 being embedded in a text...\n\n"
"DE-AD-BE-EF-00-02\n"
"12:34:56:78:9A:BC\n"
"AA:BB:CC:DD:EE:FF\n"
"DE:AD:BE:EF:00:01\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")