#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "FIRST\|(?:(?!SECOND\|[^B])[\S\s])*?SECOND\|B"
Local $sString = "FIRST|[some text here] (newline)" & @CRLF & _
"[insert text here] (newline)" & @CRLF & _
"SECOND|A (newline)" & @CRLF & _
"" & @CRLF & _
"FIRST|[some text here] (newline)" & @CRLF & _
"[insert text here] (newline)" & @CRLF & _
"SECOND|B (newline)" & @CRLF & _
"" & @CRLF & _
"FIRST|[some text here] (newline)" & @CRLF & _
"[insert text here] (newline)" & @CRLF & _
"SECOND|A (newline)" & @CRLF & _
"" & @CRLF & _
"FIRST|[some text here] (newline)" & @CRLF & _
"[insert text here] (newline)" & @CRLF & _
"SECOND|B (newline)" & @CRLF & _
"" & @CRLF & _
"FIRST|[some text here] (newline)" & @CRLF & _
"[insert text here] (newline)" & @CRLF & _
"SECOND|A (newline)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")