$re = '/^(\S+)\s+(.*)\s+(\S+)$/m';
$str = '100k melon 8
200 knife 7k
1.2m maple logs 19
42 the world\'s hardest-to-describe product may go here and you may even resort to 99 digits and more 5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);