package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:https?:\/\/)?(?:www\.)?((?:[a-zA-Z\x{00a1}-\x{ffff}0-9.\-])+(?:\.[a-zA-Z]{2,63}))`)
var str = `https://www.autoitscript.com.tr/
www.autoitscript.de
http://www.autoitscript.co.uk
http://autoitscript.tr
autoit-script.fr`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}