$re = '/\d{5,}/m';
$str = '“Invoice released for payment: Invoice #: 2555277”';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);