$re = '/((?:\G(?!^)|STRING).*?)\)/m';
$str = 'foo)bar)baz STRING foo)bar)baz)';
$subst = "$1)add-something-here...";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;