#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)cow\n([\s\S]*?)\nmilk"
Local $sString = "Their" & @CRLF & _
"cow" & @CRLF & _
"gives" & @CRLF & _
"more" & @CRLF & _
"milk" & @CRLF & _
"" & @CRLF & _
"His" & @CRLF & _
"cow" & @CRLF & _
"gives" & @CRLF & _
"less" & @CRLF & _
"milk"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")