#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)AS "(.+)\.(.+)""
Local $sString = " table1.field1 AS "table1.field1"," & @CRLF & _
" table2.field2 AS "table2.field2"," & @CRLF & _
" table3.field3 AS "table3.field3"," & @CRLF & _
" table4.field1 AS "table4.field1"," & @CRLF & _
" table4.field1 AS "table5.field5"," & @CRLF & _
" table6.field6 AS "table6.field1","
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")