using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"AS ""(.+)\.(.+)""";
string input = @" table1.field1 AS ""table1.field1"",
table2.field2 AS ""table2.field2"",
table3.field3 AS ""table3.field3"",
table4.field1 AS ""table4.field1"",
table4.field1 AS ""table5.field5"",
table6.field6 AS ""table6.field1"",";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}