import re
regex = re.compile(r"AS \"(.+)\.(.+)\"", flags=re.MULTILINE)
test_str = (" table1.field1 AS \"table1.field1\",\n"
" table2.field2 AS \"table2.field2\",\n"
" table3.field3 AS \"table3.field3\",\n"
" table4.field1 AS \"table4.field1\",\n"
" table4.field1 AS \"table5.field5\",\n"
" table6.field6 AS \"table6.field1\",")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")