// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)AS "(.+)\.(.+)""#).unwrap();
let string = " table1.field1 AS \"table1.field1\",
table2.field2 AS \"table2.field2\",
table3.field3 AS \"table3.field3\",
table4.field1 AS \"table4.field1\",
table4.field1 AS \"table5.field5\",
table6.field6 AS \"table6.field1\",";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}