#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+(-\d+)?$"
Local $sString = "01" & @CRLF & _
"02" & @CRLF & _
"03" & @CRLF & _
"04" & @CRLF & _
"05" & @CRLF & _
"101-1" & @CRLF & _
"101-2" & @CRLF & _
"101-3" & @CRLF & _
"Name1" & @CRLF & _
"Name2" & @CRLF & _
"Name3" & @CRLF & _
"Name4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")