// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-z])0( [a-z])").unwrap();
let string = "Eg.1 a0 p
Eg.2 p0 sa
Eg.3 ap0 l";
let substitution = "$1.$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}