#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^([\s]+)?(var|let|const)?([\s]+)?([a-z=\s]+)(\()(.+)?(\))([\s]+)?([\n]+)?(\{)"
Local $sString = "function func (foo) {}" & @CRLF & _
"" & @CRLF & _
"var func = function() {}" & @CRLF & _
"" & @CRLF & _
"function func () {" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"var func = function() {" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"function func ()" & @CRLF & _
"{" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"var func = function()" & @CRLF & _
"{" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"function func () {}" & @CRLF & _
"" & @CRLF & _
"var func = function() {}" & @CRLF & _
"" & @CRLF & _
"function func () {" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"var func = function() {" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"function func () " & @CRLF & _
"{" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"var func = function() " & @CRLF & _
"{" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" function func () {}" & @CRLF & _
"" & @CRLF & _
" var func = function() {}" & @CRLF & _
"" & @CRLF & _
" function func () {" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
" var func = function() {" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
" function func () " & @CRLF & _
"{" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
" var func = function() " & @CRLF & _
"{" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")