re = /^([\s]+)?(var|let|const)?([\s]+)?([a-z=\s]+)(\()(.+)?(\))([\s]+)?([\n]+)?(\{)/mi
str = 'function func (foo) {}
var func = function() {}
function func () {
}
var func = function() {
}
function func ()
{
}
var func = function()
{
}
function func () {}
var func = function() {}
function func () {
}
var func = function() {
}
function func ()
{
}
var func = function()
{
}
function func () {}
var func = function() {}
function func () {
}
var func = function() {
}
function func ()
{
}
var func = function()
{
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end