// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^([\s]+)?(var|let|const)?([\s]+)?([a-z=\s]+)(\()(.+)?(\))([\s]+)?([\n]+)?(\{)").unwrap();
let string = "function func (foo) {}
var func = function() {}
function func () {
}
var func = function() {
}
function func ()
{
}
var func = function()
{
}
function func () {}
var func = function() {}
function func () {
}
var func = function() {
}
function func ()
{
}
var func = function()
{
}
function func () {}
var func = function() {}
function func () {
}
var func = function() {
}
function func ()
{
}
var func = function()
{
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}