#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^.[^,]*(?=(\,))"
Local $sString = "C:\Program Files\EnCase21\Lib\Mobile\EnCaseMobileInstaller.msi, 9092, (NULL), (NULL), (NULL), (NULL)" & @CRLF & _
"C:\Program Files\EnCase21\Lib\Mobile\EnCaseMobileInstaller.msi" & @CRLF & _
"EnCaseMobileInstaller.msi" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")