using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.[^,]*(?=(\,))";
string input = @"C:\Program Files\EnCase21\Lib\Mobile\EnCaseMobileInstaller.msi, 9092, (NULL), (NULL), (NULL), (NULL)
C:\Program Files\EnCase21\Lib\Mobile\EnCaseMobileInstaller.msi
EnCaseMobileInstaller.msi
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}