import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.[^,]*(?=(\\,))";
final String string = "C:\\Program Files\\EnCase21\\Lib\\Mobile\\EnCaseMobileInstaller.msi, 9092, (NULL), (NULL), (NULL), (NULL)\n"
+ "C:\\Program Files\\EnCase21\\Lib\\Mobile\\EnCaseMobileInstaller.msi\n"
+ "EnCaseMobileInstaller.msi\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}