re = /^.[^,]*(?=(\,))/
str = 'C:\\Program Files\\EnCase21\\Lib\\Mobile\\EnCaseMobileInstaller.msi, 9092, (NULL), (NULL), (NULL), (NULL)
C:\\Program Files\\EnCase21\\Lib\\Mobile\\EnCaseMobileInstaller.msi
EnCaseMobileInstaller.msi
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end